using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(?=[A-ZА-Я])";
string substitution = @"{csvnc}";
string input = @"Страна: Турция Производитель: Makel Серия: Mimoza Артикул: 10321 Цвет: белый Способ монтажа: скрытый Тип серии: рамочная Номинальное напряжение: 250 В";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}