using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b0|([0-9])(?=0*~[0-9]*?\1([0-9]))|~[0-9]*";
string substitution = @"$2";
string input = @"48";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}