import Foundation
let pattern = #"\b0|([0-9])(?=0*~[0-9]*?\1([0-9]))|~[0-9]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"48"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)