package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(http.*)`)
var str = `http://www.mylink.com
http://example.com
https://www.example.net`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}