import re
regex = re.compile(r"^(http.*)", flags=re.MULTILINE)
test_str = ("http://www.mylink.com\n"
"http://example.com\n"
"https://www.example.net")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)