$re = '/^(http.*)/m';
$str = 'http://www.mylink.com
http://example.com
https://www.example.net';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;