re = /^(http.*)/m
str = 'http://www.mylink.com
http://example.com
https://www.example.net'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result