re = /^[^A-Z]+/m
str = '01. A little love (2002)
02 - No.1 Star
03 Love Story'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result