const regex = /^[^\d]*?(\+?\d\d)?(?:[^\d]*?0)?(?:[^\d]*?([1-9]))((?:[^\d]*?\d\d){4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\d]*?(\\+?\\d\\d)?(?:[^\\d]*?0)?(?:[^\\d]*?([1-9]))((?:[^\\d]*?\\d\\d){4})$', 'gm')
const str = `0674420606
06 74 42 06 06
06/74/42/06/06
06-74-42-06-06
06.74.42.06.06
+33674420606
+330674420606
+33 6 74 42 06 06
(+33)674420606
(+33) 674420606
+33 0674420606
// ^[^\\d]*?(\\+?\\d\\d)?(?:[^\\d]*?0)?(?:[^\\d]*?([1-9]))((?:[^\\d]*?\\d\\d){4})\$
// [^\\d+]
// ^[^\\d]?(\\+?\\d\\d)?0?([1-9])((?:\\d\\d){4})\$
// ^\\+?\\+?\\d\\d?0?[1-9](?:\\d\\d){4}\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}