import Foundation
let pattern = #"^[^\d]*?(\+?\d\d)?(?:[^\d]*?0)?(?:[^\d]*?([1-9]))((?:[^\d]*?\d\d){4})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0674420606
06 74 42 06 06
06/74/42/06/06
06-74-42-06-06
06.74.42.06.06
+33674420606
+330674420606
+33 6 74 42 06 06
(+33)674420606
(+33) 674420606
+33 0674420606
// ^[^\d]*?(\+?\d\d)?(?:[^\d]*?0)?(?:[^\d]*?([1-9]))((?:[^\d]*?\d\d){4})$
// [^\d+]
// ^[^\d]?(\+?\d\d)?0?([1-9])((?:\d\d){4})$
// ^\+?\+?\d\d?0?[1-9](?:\d\d){4}$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)