use strict;
my $str = '0674420606
06 74 42 06 06
06/74/42/06/06
06-74-42-06-06
06.74.42.06.06
+33674420606
+330674420606
+33 6 74 42 06 06
(+33)674420606
(+33) 674420606
+33 0674420606
// ^[^\\d]*?(\\+?\\d\\d)?(?:[^\\d]*?0)?(?:[^\\d]*?([1-9]))((?:[^\\d]*?\\d\\d){4})$
// [^\\d+]
// ^[^\\d]?(\\+?\\d\\d)?0?([1-9])((?:\\d\\d){4})$
// ^\\+?\\+?\\d\\d?0?[1-9](?:\\d\\d){4}$';
my $regex = qr/^[^\d]*?(\+?\d\d)?(?:[^\d]*?0)?(?:[^\d]*?([1-9]))((?:[^\d]*?\d\d){4})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}