# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\d]*?(\+?\d\d)?(?:[^\d]*?0)?(?:[^\d]*?([1-9]))((?:[^\d]*?\d\d){4})$"
test_str = ("0674420606\n"
"06 74 42 06 06\n"
"06/74/42/06/06\n"
"06-74-42-06-06\n"
"06.74.42.06.06\n"
"+33674420606\n"
"+330674420606\n"
"+33 6 74 42 06 06\n"
"(+33)674420606\n"
"(+33) 674420606\n"
"+33 0674420606\n\n"
"// ^[^\\d]*?(\\+?\\d\\d)?(?:[^\\d]*?0)?(?:[^\\d]*?([1-9]))((?:[^\\d]*?\\d\\d){4})$\n\n"
"// [^\\d+]\n"
"// ^[^\\d]?(\\+?\\d\\d)?0?([1-9])((?:\\d\\d){4})$\n"
"// ^\\+?\\+?\\d\\d?0?[1-9](?:\\d\\d){4}$")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.