#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Z]+(?:_[A-Z]+)*).*(?:_(\d+)\.(?:png|jpe?g|PNG|JPE?G)|\.(?:png|jpe?g|PNG|JPE?G)_(\d+))$"
Local $sString = "ET_PRH_4_20170309140404.png" & @CRLF & _
"" & @CRLF & _
"gosalyn.png_20170309140404" & @CRLF & _
"AIRLINECODE_PARTNERCODE_INVOICENO_20170309140404.png" & @CRLF & _
"" & @CRLF & _
"FILENAME.png_20170309140404"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")