import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z]+(?:_[A-Z]+)*).*(?:_(\\d+)\\.(?:png|jpe?g|PNG|JPE?G)|\\.(?:png|jpe?g|PNG|JPE?G)_(\\d+))$";
final String string = "ET_PRH_4_20170309140404.png\n\n"
+ "gosalyn.png_20170309140404\n"
+ "AIRLINECODE_PARTNERCODE_INVOICENO_20170309140404.png\n\n"
+ "FILENAME.png_20170309140404";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}