import Foundation
let pattern = #"^([A-Z]+(?:_[A-Z]+)*).*(?:_(\d+)\.(?:png|jpe?g|PNG|JPE?G)|\.(?:png|jpe?g|PNG|JPE?G)_(\d+))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ET_PRH_4_20170309140404.png
gosalyn.png_20170309140404
AIRLINECODE_PARTNERCODE_INVOICENO_20170309140404.png
FILENAME.png_20170309140404
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)