const regex = new RegExp('^([A-Z]+(?:_[A-Z]+)*).*(?:_(\\d+)\\.(?:png|jpe?g|PNG|JPE?G)|\\.(?:png|jpe?g|PNG|JPE?G)_(\\d+))$', 'gm')
const str = `ET_PRH_4_20170309140404.png
gosalyn.png_20170309140404
AIRLINECODE_PARTNERCODE_INVOICENO_20170309140404.png
FILENAME.png_20170309140404`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}