re = /^([A-Z]+(?:_[A-Z]+)*).*(?:_(\d+)\.(?:png|jpe?g|PNG|JPE?G)|\.(?:png|jpe?g|PNG|JPE?G)_(\d+))$/m
str = 'ET_PRH_4_20170309140404.png
gosalyn.png_20170309140404
AIRLINECODE_PARTNERCODE_INVOICENO_20170309140404.png
FILENAME.png_20170309140404'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end