using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Z]+(?:_[A-Z]+)*).*(?:_(\d+)\.(?:png|jpe?g|PNG|JPE?G)|\.(?:png|jpe?g|PNG|JPE?G)_(\d+))$";
string input = @"ET_PRH_4_20170309140404.png
gosalyn.png_20170309140404
AIRLINECODE_PARTNERCODE_INVOICENO_20170309140404.png
FILENAME.png_20170309140404";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}