#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?:" & @CRLF & _
" " \s* " & @CRLF & _
" (?=" & @CRLF & _
" (?: SELECT | FROM )" & @CRLF & _
" )" & @CRLF & _
" | " & @CRLF & _
" (?<! ^ )" & @CRLF & _
" \G " & @CRLF & _
")" & @CRLF & _
"[^"]*? " & @CRLF & _
"\K " & @CRLF & _
"( SELECT | FROM ) # (1)" & @CRLF & _
""
Local $sString = "" & @CRLF & _
" SELECT * FROM main -- will not match (not in a string)" & @CRLF & _
" "SELECT name FROM main" -- will match" & @CRLF & _
" "" & @CRLF & _
" SELECT name FROM main" -- will match" & @CRLF & _
" """Here is a SQL statement:" & @CRLF & _
"" & @CRLF & _
"SELECT * FROM main""" -- no, string does not start with a keyword (SELECT...)." & @CRLF & _
"" & @CRLF & _
""SELECT * FROM table"" & @CRLF & _
""" & @CRLF & _
" SELECT * FROM table"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")