import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\n"
+ " \" \\s* \n"
+ " (?=\n"
+ " (?: SELECT | FROM )\n"
+ " )\n"
+ " | \n"
+ " (?<! ^ )\n"
+ " \\G \n"
+ ")\n"
+ "[^\"]*? \n"
+ "\\K \n"
+ "( SELECT | FROM ) # (1)\n";
final String string = "\n"
+ " SELECT * FROM main -- will not match (not in a string)\n"
+ " \"SELECT name FROM main\" -- will match\n"
+ " \"\n"
+ " SELECT name FROM main\" -- will match\n"
+ " \"\"\"Here is a SQL statement:\n\n"
+ "SELECT * FROM main\"\"\" -- no, string does not start with a keyword (SELECT...).\n\n"
+ "\"SELECT * FROM table\"\n"
+ "\"\n"
+ " SELECT * FROM table\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}