$re = '/(?:
" \s*
(?=
(?: SELECT | FROM )
)
|
(?<! ^ )
\G
)
[^"]*?
\K
( SELECT | FROM ) # (1)
/x';
$str = '
SELECT * FROM main -- will not match (not in a string)
"SELECT name FROM main" -- will match
"
SELECT name FROM main" -- will match
"""Here is a SQL statement:
SELECT * FROM main""" -- no, string does not start with a keyword (SELECT...).
"SELECT * FROM table"
"
SELECT * FROM table"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);