# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\\/Services\\/(?'var'[[:alnum:]_-]+)|\G(?!\A))(?:\\/(?'params'[[:alnum:]_-]+))?//g;t' <<< "/Services/Inventaire/Ok/Boo/Test"