import Foundation
let pattern = #"(?:\/Services\/(?'var'[[:alnum:]_-]+)|\G(?!\A))(?:\/(?'params'[[:alnum:]_-]+))?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/Services/Inventaire/Ok/Boo/Test"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)