$re = '/(?:\/Services\/(?\'var\'[[:alnum:]_-]+)|\G(?!\A))(?:\/(?\'params\'[[:alnum:]_-]+))?/';
$str = '/Services/Inventaire/Ok/Boo/Test';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;