re = /(?:\/Services\/(?'var'[[:alnum:]_-]+)|\G(?!\A))(?:\/(?'params'[[:alnum:]_-]+))?/
str = '/Services/Inventaire/Ok/Boo/Test'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result