const regex = /\x{FEFF}+|\x{01CE}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\x{FEFF}+|\\x{01CE}', 'g')
const str = `خيابانمولوينرسيدهبهقيا
ǎǎǎǎǎǎǎǎ`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);