use strict;
my $str = 'خيابانمولوينرسيدهبهقيا
ǎǎǎǎǎǎǎǎ';
my $regex = qr/\x{FEFF}+|\x{01CE}/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";