#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "{if ([^}]+)}([\W\w]*?)(?:{else}([\W\w]*?))?{\/if}"
Local $sString = "{if $module=admin}" & @CRLF & _
"" & @CRLF & _
"{/if}" & @CRLF & _
"" & @CRLF & _
"{if $module=admin}" & @CRLF & _
"blah{invalid} blah" & @CRLF & _
"{else}" & @CRLF & _
"sdf" & @CRLF & _
"{/if}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")