// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"{if ([^}]+)}([\W\w]*?)(?:{else}([\W\w]*?))?{\/if}").unwrap();
let string = "{if $module=admin}
{/if}
{if $module=admin}
blah{invalid} blah
{else}
sdf
{/if}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}