const regex = /{if ([^}]+)}([\W\w]*?)(?:{else}([\W\w]*?))?{\/if}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{if ([^}]+)}([\\W\\w]*?)(?:{else}([\\W\\w]*?))?{\\\/if}', 'g')
const str = `{if \$module=admin}
{/if}
{if \$module=admin}
blah{invalid} blah
{else}
sdf
{/if}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}