$re = '/{if ([^}]+)}([\W\w]*?)(?:{else}([\W\w]*?))?{\/if}/';
$str = '{if $module=admin}
{/if}
{if $module=admin}
blah{invalid} blah
{else}
sdf
{/if}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);