using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{if ([^}]+)}([\W\w]*?)(?:{else}([\W\w]*?))?{\/if}";
string input = @"{if $module=admin}
{/if}
{if $module=admin}
blah{invalid} blah
{else}
sdf
{/if}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}