re = /{if ([^}]+)}([\W\w]*?)(?:{else}([\W\w]*?))?{\/if}/
str = '{if $module=admin}
{/if}
{if $module=admin}
blah{invalid} blah
{else}
sdf
{/if}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end