const regex = /((<br>\s*)\1?)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((<br>\\s*)\\1?)+', 'g')
const str = `Addendum 5 changes the following:<div><br><br>
<br></div>div<br>div> Addenda 5 - Landscape
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>Item
<br>Description
<br>Qty
<br>Unit
<br>`;
const subst = `<br />`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);