#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s"
Local $sString = "20-03-2020 00:22:12"
Local $sSubst = "A"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)