package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s`)
var str = `20-03-2020 00:22:12`
var substitution = "A"
fmt.Println(re.ReplaceAllString(str, substitution))
}