using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s";
string substitution = @"A";
string input = @"20-03-2020 00:22:12";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}