// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s").unwrap();
let string = "20-03-2020 00:22:12";
let substitution = "A";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}