const regex = /\s/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s', 'g')
const str = `20-03-2020 00:22:12`;
const subst = `A`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);