$re = '/\s/';
$str = '20-03-2020 00:22:12';
$subst = "A";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;