using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s-)|(?:,\s)|(?:\sand\s)";
string input = @"First Filename - 2016-04.pdf
Second Filename and another name.mp3
Third.jpg
Fourth Filename, 2016.pdf
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}