import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s-)|(?:,\\s)|(?:\\sand\\s)";
final String string = "First Filename - 2016-04.pdf \n"
+ "Second Filename and another name.mp3\n"
+ "Third.jpg\n"
+ "Fourth Filename, 2016.pdf\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}