re = /(?:\s-)|(?:,\s)|(?:\sand\s)/mi
str = 'First Filename - 2016-04.pdf
Second Filename and another name.mp3
Third.jpg
Fourth Filename, 2016.pdf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end