// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?:\s-)|(?:,\s)|(?:\sand\s)").unwrap();
let string = "First Filename - 2016-04.pdf
Second Filename and another name.mp3
Third.jpg
Fourth Filename, 2016.pdf
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}