import re
regex = re.compile(r"(?:\s-)|(?:,\s)|(?:\sand\s)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("First Filename - 2016-04.pdf \n"
"Second Filename and another name.mp3\n"
"Third.jpg\n"
"Fourth Filename, 2016.pdf\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")