using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{3}(?:(?:[ \.\-]?)\d{2}){3}$";
string input = @"123456789
123 45 67 89
123.45.67.89
123-45-67-89
1234
1341234311341324";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}