re = /^\d{3}(?:(?:[ \.\-]?)\d{2}){3}$/m
str = '123456789
123 45 67 89
123.45.67.89
123-45-67-89
1234
1341234311341324'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end