$re = '/^\d{3}(?:(?:[ \.\-]?)\d{2}){3}$/m';
$str = '123456789
123 45 67 89
123.45.67.89
123-45-67-89
1234
1341234311341324';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);