import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{3}(?:(?:[ \\.\\-]?)\\d{2}){3}$";
final String string = "123456789\n"
+ "123 45 67 89\n"
+ "123.45.67.89\n"
+ "123-45-67-89\n"
+ "1234\n"
+ "1341234311341324";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}