// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{3}(?:(?:[ \.\-]?)\d{2}){3}$").unwrap();
let string = "123456789
123 45 67 89
123.45.67.89
123-45-67-89
1234
1341234311341324";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}